kloxo升级到新版500错误和空白页的解决方法

今天早上起床后开机,顺手打开自己的网站地址,竟然发现浏览器白茫茫一片,啥也不显示,换浏览器也一样,打开代理再访问还是如此,看来是出问题了哦。尝试着用从浏览器输入站点的图片地址能打开,看来是php出问题了。

登陆Kloxo后台,奇怪了,界面怎么和以前不一样了,查看版本,竟然自动升级到了Kloxo 6.1.19版,卖糕的,我关闭了自动更新了啊,肿么还是升级了。

111

新版的Kloxo 中PHP更新到了5.2.17-13及以上的高版本,这些版本自带了php-fpm组件,在Kloxo中如果设置了以php-cgi方式运行PHP,就会在Apache下出现500错误,在lighttpd下显示空白页的问题,解决办法就是将PHP从最新版本降级到5.2.17-1。

以下是操作步骤:

打开命令控制台,

112

在第一个输入框输入:

yum downgrade php php-cli php-common php-devel php-gd php-imap php-mbstring php-mcrypt php-mysql php-pdo php-xml -y

113

点击下面的执行按钮运行命令,然后在第二个框中显示返回的结果,

114

Removed:
php.i386 0:5.1.6-27.el5_7.4              php-cli.i386 0:5.1.6-27.el5_7.4
php-common.i386 0:5.1.6-27.el5_7.4       php-devel.i386 0:5.1.6-27.el5_7.4
php-gd.i386 0:5.1.6-27.el5_7.4           php-imap.i386 0:5.1.6-27.el5_7.4
php-mbstring.i386 0:5.1.6-27.el5_7.4     php-mysql.i386 0:5.1.6-27.el5_7.4
php-pdo.i386 0:5.1.6-27.el5_7.4          php-xml.i386 0:5.1.6-27.el5_7.4
Installed:
php.i386 0:5.1.6-27.el5_5.3              php-cli.i386 0:5.1.6-27.el5_5.3
php-common.i386 0:5.1.6-27.el5_5.3       php-devel.i386 0:5.1.6-27.el5_5.3
php-gd.i386 0:5.1.6-27.el5_5.3           php-imap.i386 0:5.1.6-27.el5_5.3
php-mbstring.i386 0:5.1.6-27.el5_5.3     php-mysql.i386 0:5.1.6-27.el5_5.3
php-pdo.i386 0:5.1.6-27.el5_5.3          php-xml.i386 0:5.1.6-27.el5_5.3
Complete!

当看最后installed中安装的PHP版本低于5.2.17-1后,问题就解决了,这时候重启一下服务器一切就正常了。

115

当然还有一个小问题我就遇到了,这个估计还是会有很多人同样会遇到,那就是降级PHP的时候,命令成功完成了,重启服务器以后还是显示空白页,这就是因为Kloxo安装的PHP版本比5.2.17-13高好几个版本,虽然installed中新安装的版本降级了,但还是没安装到5.2.17-1版,比如我今天遇到的就是卸载PHP后在installed显示的新安装的PHP版本是5.2.17-13,然后重启服务器故障依旧,这时候在命令控制台再用刚才的命令降级一次或者多次,直到installed显示的新安装的PHP版本等于或者低于5.2.17-1为止,这是再重新启动服务器,问题就解决了。

还有一点就是记得在常规设置中将自动更新前面的勾勾取消掉哦。

0
如无特殊说明,文章均为本站原创,转载请注明出处

该文章由 发布

这货来去如风,什么鬼都没留下!!!
发表我的评论

Hi,请填写昵称和邮箱!

取消评论
代码 贴图 加粗 链接 删除线 签到

(1)条精彩评论:
  1. 尚吾网
    转眼一年已过一半,再次来访,继续支持
    尚吾网2014-06-03 17:50 回复